openmeetings-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SebastianWagner (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (OPENMEETINGS-570) Some issues with device settings and attach Camera
Date Sun, 17 Mar 2013 02:24:12 GMT

    [ https://issues.apache.org/jira/browse/OPENMEETINGS-570?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13604482#comment-13604482
] 

SebastianWagner edited comment on OPENMEETINGS-570 at 3/17/13 2:22 AM:
-----------------------------------------------------------------------

URL: http://svn.apache.org/r1457361
Log:
Improves OPENMEETINGS-570, but does not fixes all use cases.

Some issue remain:

a) you still can provoke the status light to stay on
 - The status ight of the cam does now switch off if you choose "no Audio/video" directly
after entering the room.
But you still can provoke it to stay on when it should go off, by:
 - If you choose some valid device settings, 
 - click on start conference
 - click on "Re-Sync" and choose "No Audio/video"
 - click on start conference
=> Result should be: The cam's status light should go off as you don't share anything.
But the status light stays on.

b) The attachCamera might be still called duplicate.
The resolutions are loaded via a datapath. The datapath initilizes not synchronized with the
camera combobox. The nature of this datapath/xPath construct is that you can't say for sure
when it will initialize and espacially when init is complete.
It should be reworked so that the resolution combobox items are initialized in the method
"initItemsAndDefaultAttachCamera" so that we can be 100% sure that the attachCamera is not
accidently called before the camera combobox is filled with items/initialized.



                
      was (Author: swagner):
    URL: http://svn.apache.org/r1457361
Log:
Improves OPENMEETINGS-570, but does not fixes all uses cases.

Some issue remain:

a) you still can provoke the status light to stay on
 - The status ight of the cam does now switch off if you choose "no Audio/video" directly
after entering the room.
But you still can provoke it to stay on when it should go off, by:
 - If you choose some valid device settings, 
 - click on start conference
 - click on "Re-Sync" and choose "No Audio/video"
 - click on start conference
=> Result should be: The cam's status light should go off as you don't share anything.
But the status light stays on.

b) The attachCamera might be still called duplicate.
The resolutions are loaded via a datapath. The datapath initilizes not synchronized with the
camera combobox. The nature of this datapath/xPath construct is that you can't say for sure
when it will initialize and espacially when init is complete.
It should be reworked so that the resolution combobox items are initialized in the method
"initItemsAndDefaultAttachCamera" so that we can be 100% sure that the attachCamera is not
accidently called before the camera combobox is filled with items/initialized.



                  
> Some issues with device settings and attach Camera
> --------------------------------------------------
>
>                 Key: OPENMEETINGS-570
>                 URL: https://issues.apache.org/jira/browse/OPENMEETINGS-570
>             Project: Openmeetings
>          Issue Type: Bug
>    Affects Versions: 2.1 Apache Release
>            Reporter: SebastianWagner
>            Assignee: SebastianWagner
>
> The problem is that the attachCamera method is invoked multiple times when the video
device settings initialize:
> 1) As soon as the two combobox'es rendered completely each will call "attachCamera" and
re-attach the video to the view (2 calls)
> 2) as soon as the user clicks "Allow" in the flash settings, the attachCamera function
is invoked again (what for ?) (1 call)
> Somehow this leads to a bug in the application that creates two videos and one is no
more resizable.
> Also the video view that the attachCamera method is using is the wrong videoview.
> There are two preview video objects in the device settings:
> a) One for the actual current webcam view (aka "_publisher")
> b) One for the playback of the 5 second self recording test video (aka "_viewer")
> The attachCamera function attaches the stream to the _viewer instead of the _publisher.
> There is also a 3th problem (that is also present when having no "attachCamera" function
enabled, but simply doing a 5 second recording test). But the auto-attaching of the Camera
to the videoview makes it more obvious:
> When you click "no Audo/Video" as device settings, your webcam still shows the "red status
light" as if some application access it. Actually this should not happen. The status light
should turn off when you don't use your webcam. The issue is that the cam is somehow not correctly
unattached from the videoview.
> The issues of the 3th problem is in the "_stop" method in the "baseVideoStream.lzx"
> _stop will only be execute a "clear" (that will un-attach the Camera from the videoview)
> if (_ns != null) //if there is a netstream attached to the video
> => In the device settings _ns is null, cause you just want to show a preview
> The effect is that _stop will never call "clear"
> By adding a manual "clear" to the attachCamera function (and when the window closes),
the camera status light goes off when you choose "no Audio/Video" as setting and click on
"start conference".
> I will try to bundle a patch for those issues now.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message