openmeetings-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Rembert (JIRA)" <>
Subject [jira] [Commented] (OPENMEETINGS-431) OpenMeetings behind a proxy doesn't work for screen sharing
Date Wed, 06 Mar 2013 18:18:12 GMT


Guillaume Rembert commented on OPENMEETINGS-431:

In fact I don't think that the problem is on the machine itself, but on the way I use it.

As I explained, I have a proxy in the middle doing https:
user machine <--> apache proxy https (443) <--> openmeetings machine http (80)

The problem is linked to the jnlp generation - file named "public_9.jnlp".
When I look inside, it is generating the following link:
<jnlp spec='1.0+' codebase=''>
> OpenMeetings behind a proxy doesn't work for screen sharing
> -----------------------------------------------------------
>                 Key: OPENMEETINGS-431
>                 URL:
>             Project: Openmeetings
>          Issue Type: Bug
>          Components: Screen-sharing
>    Affects Versions: 2.1 Apache Release
>         Environment: CentOS 6.3 + OpenMeetings Nightly Build
>            Reporter: Guillaume Rembert
>            Assignee: Maxim Solodovnik
>            Priority: Minor
>              Labels: apache, forward, front-end
>             Fix For: 2.1 Apache Release
> First, thanks Maxim for your answer and sorry to re-open it, I used a newer version -
2.1.0.r1428678-04-01-2013 and still have some issues (not the latest, I just tried to upgrade,
but it failed to start and I got many error messages), so maybe it is already fixed. Just
to explain the configuration better:
> Public IPv4 Network - Forwarded Ports : 443/https to Machine 1 + 8088/rtmpT to Machine
> Machine 1 : Apache Server https over 443 / proxy to Machine 2 clear http
> Machine 2 : OpenMeetings Server - configuration: http over 5080 + rtmpT over 8088
> Everything works fine here except the part where you click on share screen, you download
 public_9.njlp and execute it in javaws.
> I get the following error:
> Unable to load resource:
> Which is normal as it try to get http on an https port. I tried to run it in my browser
and get the confirmation:
> <html><head>
> <title>400 Bad Request</title>
> </head><body>
> <h1>Bad Request</h1>
> <p>Your browser sent a request that this server could not understand.<br />
> Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
> Instead use the HTTPS scheme to access this URL, please.<br />
> <blockquote>Hint: <a href=""><b></b></a></blockquote></p>
> </body></html>
> Maybe I am not configuring it properly, but I think that it might be a tiny bug. For
you to check, the related part of config.xml:
> <!-- 
> Port to use for the Server
> This port is used to connect to the http-servlet
> of the red5-servlet
>  -->
> <red5httpport>443</red5httpport>
> <!--
>     The protocol to use for the http connections
>     for example upload/download of files 
>  -->
> <protocol>https</protocol>
> I'll put my hands in the code to try to solve this and help a bit, but in case you know
where it is...

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message