openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de>
Subject Re: Incorrect import range for javax.transaction makes openjpa incompatible to jta 1.2
Date Thu, 20 Aug 2015 20:58:51 GMT
Hi Christian!

JPA-2.0 is specified to use JTA-1.1.
Otoh there are just a few additional Classes in there and the rest remained unchanged.
Thus it’s imo fine to include this in the import definition.

I have a few more things on my list which I like to ship anyway, so I can do a 2.4.1 release
in the next 2 weeks.
Please add a patch to the jira. Gonna apply it.

LieGrue,
strub



> Am 20.08.2015 um 11:24 schrieb Christian Schneider <chris@die-schneider.net>:
> 
> We recently updated karaf to use jta 1.2 as it provides a standard @Transactional annotation
for usage in user code.
> 
> The problem is that openjpa does not work with jta 1.2. As far as I can tell the issue
is only an incorrect import range.
> I opened an issue for this but got no response till now:
> https://issues.apache.org/jira/browse/OPENJPA-2607
> 
> There is also a much older issue to create a karaf feature file during the openjpa build:
> https://issues.apache.org/jira/browse/OPENJPA-2465
> 
> As we just released karaf 4.0.1 it will take about a month till the next bugfix release.
We need new openjpa releases with at least the first issue solved. Until then openjpa will
not work correctly in karaf with aries transaction 1.1.x.
> 
> I can do the work of creating the patches or github pull requests if you prefer.
> 
> Christian
> 
> -- 
> Christian Schneider
> http://www.liquid-reality.de
> 
> Open Source Architect
> http://www.talend.com
> 


Mime
View raw message