openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de>
Subject Re: Which version of JPA (2.0 or 2.1) does openjpa 2.4 support?
Date Mon, 06 Apr 2015 12:13:40 GMT
> OK, so can I suggest that the web page needs updating as it is currently
> misleading.

Oh, thanks for the pointer!

> Also why do you suppose that Eclipse seems to think that the openjpa
> jar file in tomee contains a 2.1 JPA implementation rather than a 2.0 one?
> It is resisting me trying to "downgrade" JPA support to 2.0 with the
> 2.4 jar installed.


Hmm, that’s weird indeed. But I guess this has more to do with Eclipse than with openjpa.

LieGrue,
strub




> Am 06.04.2015 um 13:15 schrieb David Goodenough <david.goodenough@btconnect.com>:
> 
> OK, so can I suggest that the web page needs updating as it is currently
> misleading.
> 
> Also why do you suppose that Eclipse seems to think that the openjpa
> jar file in tomee contains a 2.1 JPA implementation rather than a 2.0 one?
> It is resisting me trying to "downgrade" JPA support to 2.0 with the
> 2.4 jar installed.
> 
> David
> 
> On Monday 06 April 2015 12:17:00 Mark Struberg wrote:
>> Hi!
>> 
>> openjpa-2.4.0 is indeed targetting JPA-2.0.
>> 
>> I personally would like to  target JPA-2.1 soon, but before that I would
>> love to see a few cleanup efforts being done. E.g. cleaning up our bytecode
>> parts and move all to xbean-asm5-shaded.
>> 
>> LieGrue,
>> strub
>> 
>>> Am 06.04.2015 um 11:15 schrieb David Goodenough
>>> <david.goodenough@btconnect.com>:
>>> 
>>> According to:-
>>> 
>>> http://openjpa.apache.org/jpa-2.1-development-process.html
>>> 
>>> openjpa 2.4 is the release that should implement JPA 2.1.  But I am told
>>> on the tomee mailing list that although tomee 2.0 included an
>>> openjpa 2.4 snapshot it does not support jpa 2.1.
>>> 
>>> I am confused, can someone enlighten me.
>>> 
>>> David
> 


Mime
View raw message