openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Curtis <curti...@gmail.com>
Subject Re: JPA metadata errors while starting TomEE
Date Tue, 24 Feb 2015 14:37:43 GMT
and configuring the javaagent fix everything?

On Mon, Feb 23, 2015 at 7:51 PM, leo ks <l6459852@gmail.com> wrote:

> I was having strange and random errors complaining of entity mapping
> between entities or unrecognized mapping between entity attributes and the
> columns in the DB
>
> 2015-02-23 22:42 GMT-03:00 Rick Curtis <curtisr7@gmail.com>:
>
> > Can you expand a bit? Were you having problems with
> > openjpa.RuntimeUnenhancedClasses?
> >
> > On Mon, Feb 23, 2015 at 5:52 PM, leo ks <l6459852@gmail.com> wrote:
> >
> > > the enhancer seems to have fixed it :-)
> > >
> > > 2015-02-23 19:17 GMT-03:00 Rick Curtis <curtisr7@gmail.com>:
> > >
> > > > What sort of errors are you seeing?
> > > >
> > > > On Mon, Feb 23, 2015 at 1:07 PM, leo ks <l6459852@gmail.com> wrote:
> > > >
> > > > > ---------- Forwarded message ----------
> > > > > From: leo ks <l6459852@gmail.com>
> > > > > Date: 2015-02-23 16:05 GMT-03:00
> > > > > Subject: JPA metadata errors while starting TomEE
> > > > > To: users@tomee.apache.org
> > > > >
> > > > >
> > > > > Hi
> > > > >
> > > > > I am using tomee 1.6.0 and I'm experiencing some strange errors
> > during
> > > > > startup.
> > > > >
> > > > > Sometimes, I get errors from JPA trying to resolve metadata
> > > > > (MetaDataException), sometimes it just starts without any problem
> and
> > > it
> > > > > works OK.
> > > > >
> > > > > I wonder if any process is starting before others (such as MDBs
> > > > processing
> > > > > persistent messages for example).
> > > > >
> > > > > What's the best practice in this situation?
> > > > >
> > > > > Cheers
> > > > >
> > > > > K.
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > *Rick Curtis*
> > > >
> > >
> >
> >
> >
> > --
> > *Rick Curtis*
> >
>



-- 
*Rick Curtis*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message