openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: Moving from OpenJPA 2.0.1 to 2.3.0: fields not found
Date Tue, 07 Oct 2014 22:43:16 GMT
Lionel,
I would suggest trying to turn on Trace, but there doesn't seem to be a lot
of tracing in this particular area of the code...  :-(  It still might be
worth a shot.  Maybe an earlier log entry might shed some light on why this
is going awry...

I'm going to suggest one quick change just to see if it makes a
difference.  It shouldn't, but I stumbled on this the first time I read
your code, so maybe the OpenJPA code is making the same mistake...

Instead of referencing a final String field for your mappedBy field, what
happens if you just insert the actual string?  For example, instead of...
    mappedBy = CAService._domainFieldName,
do this...
    mappedBy = "domains",

I know it shouldn't make a difference, but it might isolate the source of
the error if this does work.

Thanks, Kevin

On Tue, Oct 7, 2014 at 10:49 AM, Lionel <lsavouillan@axway.com> wrote:

> Hello,
>
> First, thanks a lot for your answer. :)
>
> In the past, we were using an ant build the project so also to run the JPA
> enhancer but for a company strategy reason we are moving to a maven build
> process.
> And when I did it, we've seen that there is a maven plugin to do the JPA
> enhancer.
> So that's why :)
>
> I just put back the default PersistenceProviderImpl and sadly, I had the
> same result. :(
>
> <provider>org.apache.openjpa.persistence.PersistenceProviderImpl</provider>
>
>
>
> To try to isolate the issue and, tonight, we will just replace the JPA
> version inside the existing project (built with ant) just to validate that
> has really no link with the enhancement.
>
> I will also try to upgrade openJPA version one by one to be sure from which
> the error appears and give additionnal data tomorrow.
>
>
>
> --
> View this message in context:
> http://openjpa.208410.n2.nabble.com/Moving-from-OpenJPA-2-0-1-to-2-3-0-fields-not-found-tp7587168p7587176.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message