openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From José Luis Cetina <maxtorz...@gmail.com>
Subject Re: openjpa.Enhance - You have enabled runtime enhancement, but have not specified the set of persistent classes.
Date Wed, 20 Aug 2014 03:25:39 GMT
Ok. Thanks Rick.
El 19/08/2014 21:12, "Rick Curtis" <curtisr7@gmail.com> escribió:

> > If i could see that the enhancement is running when i clean and install
> the pom of my maven project, then why this message is show?
> I believe this message is just telling you that TomEE has enabled the
> OpenJPA runtime enhancer. I'm pretty certain you can ignore the message.
>
> Thanks,
> Rick
>
>
> On Tue, Aug 19, 2014 at 12:26 PM, José Luis Cetina <maxtorzito@gmail.com>
> wrote:
>
> > Hi, i have a maven project, in my project i have a maven plugin for
> > enhancement, when i execute the plugin i can see the "enhancement
> running"
> > lines for each entity, like this:
> >
> > INFO   [main] openjpa.Tool - Enhancer running on type "class
> > com.xx.yy.zz.MyClassName".
> >
> >
> > But when i run my server (Apache TomEE 1.6.0) i see a warning message:
> >
> > 239  classpath-bootstrap  INFO   [main] openjpa.Enhance - You have
> enabled
> > runtime enhancement, but have not specified the set of persistent
> classes.
> >  OpenJPA must look for metadata for every loaded class, which might
> > increase class load times significantly.
> >
> > If i could see that the enhancement is running when i clean and install
> the
> > pom of my maven project, then why this message is show?
> >
> >
> > Plugin:
> >
> >  <!--OPENJPA ENHANCMENT-->
> >             <plugin>
> >                 <groupId>org.apache.openjpa</groupId>
> >                 <artifactId>openjpa-maven-plugin</artifactId>
> >                 <version>${plugins.openjpa.maven.plugin}</version>
> >                 <configuration>
> >                     <includes>
> >                         com/xx/yy/entities/**/*
> >                     </includes>
> >                     <excludes>
> >                         com/xx/yy/entities/**/*_.class
> >                     </excludes>
> >                     <addDefaultConstructor>true</addDefaultConstructor>
> >
> > <enforcePropertyRestrictions>true</enforcePropertyRestrictions>
> >                 </configuration>
> >                 <executions>
> >                     <execution>
> >                         <id>enhancer</id>
> >                         <phase>process-classes</phase>
> >                         <goals>
> >                             <goal>enhance</goal>
> >                         </goals>
> >                     </execution>
> >                 </executions>
> >                 <dependencies>
> >                     <dependency>
> >                         <groupId>org.apache.openjpa</groupId>
> >                         <artifactId>openjpa</artifactId>
> >                         <version>${apache.openjpa.version}</version>
> >                     </dependency>
> >                 </dependencies>
> >             </plugin>
> >
>
>
>
> --
> *Rick Curtis*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message