openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: OpenJPA not generating/mapping DB tables from EJB entities
Date Mon, 09 Dec 2013 16:40:21 GMT
No problem, wlad.  There are always beginner questions.  It's good to have
these documented for future newbies...  :-)


On Mon, Dec 9, 2013 at 9:41 AM, wlad <vvozar@yahoo.com> wrote:

> Hi Kevin,
>
> MY FAULT!!! I haven't created database before trying to map entities, and
> that's why i was getting this connection exception (I am new to JEE world
> and still learning).
>
> Above code and settings are fine. I thought that persistence
> provider(openJPA) is creating not only database tables, but database itself
> also. I thought that, because of given "JdbcUrl property" in the datasource
> definition (which contains db name). Obviously, i need to have created
> database, and persistence provider is creating just tables to already
> existing database. So, I have (explicitly) created database from mysql
> terminal command "create database Vezbe09;" , deployed my app, run above
> ant
> task that triggers openJPA, and I got tables in my database.
>
> (To be honest, I felt a little embarrassed when i realized how obvious
> thing
> i missed, so I thought it would be better to remove this topic)
>
> Anyway, thanks for explanations.
>
>
>
>
> --
> View this message in context:
> http://openjpa.208410.n2.nabble.com/Re-OpenJPA-not-generating-mapping-DB-tables-from-EJB-entities-tp7585739p7585741.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message