openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: JPA Enhancement with Eclipse and Ant: Class not found Exception
Date Tue, 08 Jan 2013 15:41:05 GMT
Besides the OpenJPA manual [1], there is also this wiki page on OpenJPA's
enhancement processing [2].  Have you referenced these for hints?

The items you referenced below (pathelement and fileset) are just used to
create the classpath required to run the enhancement process.  You are free
to use whatever OpenJPA you have available (download, TomEE, WebSphere,
where ever the binaries can be found).

Based on the error you posted, I would guess your classpath isn't setup
correctly.

Good luck,
Kevin

[1]
http://openjpa.apache.org/builds/latest/docs/docbook/manual.html#ref_guide_pc_enhance
[2]  http://openjpa.apache.org/entity-enhancement.html

On Tue, Jan 8, 2013 at 7:03 AM, Jérôme <the_supergg@hotmail.com> wrote:

> Hi vinbr88 and OpenJPA users ,
>
> I know it has been a while since you post this but I have some questions !
> Firstly thanks to letting us know how you solve your problem.
>
> I'm trying to do the same as you and I got some problems and there is some
> stuff that I don't understand (first time I play with ant)
>
>             <pathelement location="build"/>
>             <pathelement location="${basedir}/build/classes"/>
>
> With this lines you specify where are your entities right ?
> Why there is two pathelements ?
>
> i'm using tomEE so all the lib like openjpa are there, do I still need to
> copy the openjpa jar into the lib dir ?
> In this line :
>
>         <fileset dir="lib">
>             <include name="**/*.jar"/>
>         </fileset>
>
> Or there is a way to use the one in tomEE ?
>
> When I try to run it I got this error :
>
> BUILD FAILED
> C:\***\workspace\Dashboard2\enhance.xml:16: java.lang.NoClassDefFoundError:
> org/apache/commons/lang/exception/NestableRuntimeException
>
> On my line 16 i have this : <openjpac>
>
> Thx in advance !
>
>
>
>
> --
> View this message in context:
> http://openjpa.208410.n2.nabble.com/JPA-Enhancement-with-Eclipse-and-Ant-Class-not-found-Exception-tp7405353p7582477.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message