openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: JPA Enhancement throws java.lang.VerifyError: JVMVRFY012 for method pcClearFields() event with version 2.3.0-SNAPSHOT under WAS 8.0.0.4
Date Mon, 01 Oct 2012 13:21:40 GMT
Hi Heiko,
*>  but currently it seems the problem only affects complex entities
included as attributes in
other entities, not attributes with primitive types or simple classes like
Integer, BigDecimal or Date.*

This is very likely...  The other issues that were recently discovered were
with "complex" entities.  It's just surprising that after all of these
years with basically the same enhancement processing that we are now
hitting issues.  Some of them were due to Java 7 verification (as
previously noted), but now this is the second one that seems unrelated to
Java 7 usage...

*>  The execution environment of WAS is however, IBM JDK 1.6 and we cannot
and did
not change that.
*
Good to hear.  :-)

*>  I will possibly open a PMR with IBM support if you think that this
would be
a good idea too.*

Yes, this would be a good idea.  Since you are experiencing this problem
with the code that came with WAS 8.0.0.4, then any eventual resolution to
the problem will need to be delivered via an APAR (iFix).  So, you might as
well get that wheel in motion.  Mention this discussion in the PMR and ask
for the PMR to be routed to the JPA L3 queue.  Thanks.

In the mean time, opening a JIRA would also be a good path.

Also, is it possible for you to provide the errant class files?  A simple
Eclipse project or Junit test that demonstrates the issue would be best.
In the past, when I have attempted to reproduce the customer's scenario in
these cases, I have not had much luck.  Not until a specific testcase was
provided.  Once we can reproduce the error, figuring out a solution is
relatively straight forward.

Thank you,
Kevin

On Sat, Sep 29, 2012 at 3:06 AM, Heiko Kopp <it-media.kopp@daimler.com>wrote:

> Kevin Sutter wrote
> > Hi Heiko,
> > More questions than answers at this point...  Thanks for digging into the
> > existing issues related to these Java Verify Issues.
> >
> > o  Does this occur when running with straight WAS 8.0.0.4 with the
> OpenJPA
> > 2.1.x deliverable?
>
> Yes it does occur with that. I only used OpenJPA 2.3.0-SNAPSHOT together
> with the OpenJPA 2.3.0-SNAPSHOT maven plugin at compile/build time to do
> the
> enhancement. At runtime, OpenJPA is not included in the package (EAR/WAR),
> and the version delivered with IBM throws the error.
>
> I will possibly open a PMR with IBM support if you think that this would be
> a good idea too. I just wanted to figure out why this happens at all.
> Interestingly, I have another application on the very same WAS using
> absolutely the same tools and this one does not have the issue. No
> errors.... Weird!
>
> In the example posted in my previous message, it seems the entity
> DbDocument
> is responsible for the cause, so I removed it, but afterwards another
> entity
> with the same problem came up. I can dig more into that, but currently it
> seems the problem only affects complex entities included as attributes in
> other entities, not attributes with primitive types or simple classes like
> Integer, BigDecimal or Date.
>
>
> Kevin Sutter wrote
> > o  Are you, by chance, building and/or executing in a Java 7 environment?
> > As you have seen by the other JIRA Issues, Java 7 automatically verifies
> > all Class files now.  Before Java 7, many of these Verify errors were
> > eaten
> > and never output to the user.
>
> Yeah I saw that almost everything seemed to be related to Java 7. The
> execution environment of WAS is however, IBM JDK 1.6 and we cannot and did
> not change that.
>
> At first I had a IBM JDK 1.7 based Eclipse + WDT Tools, but after reading
> the issues with Java 7 and enhancements, I've completely removed Java 7
> SDKs/JREs from Eclipse and run Eclipse with the JDK shipped with IBM WAS
> (which is IBM SDK 1.6 SP2). I'm stuck to IBM SDKs here, as the WDT Tools
> only allow deployment to secured WebSphere Servers when Eclipse is setup
> with an IBM SDK :-(
>
>
> Kevin Sutter wrote
> > o  How are you doing the enhancement processing?  Are you doing
> > enhancement
> > at build time, or dynamically at runtime via the Container hook?
>
> Both, by default we use the org.apache.openjpa/openjpa-maven-plugin version
> 2.2.0 for build time enhancement in maven phase 'process-classes'. I
> changed
> to use the 2.3.0-SNAPSHOT version (which definitely used Serp 1.14.1 - we
> checked that too) when I saw the related issues, but: => the error occurs
> in
> both cases.
>
> Then, I completely disabled runtime enhancement by commenting out the
> plugin
> in the maven pom file, verified, that the class-files do not include any
> enhancements in the built EAR and deployed the application to WAS. => The
> error occurs too.
>
> So to answer your question. It happens in both ways, when enhancing at
> build
> time and at runtime.
>
> Thank you for your rapid response Kevin,
>
> looking forward to hearing your thoughts on this.
>
> Best regards,
>
> Heiko
>
>
>
> --
> View this message in context:
> http://openjpa.208410.n2.nabble.com/JPA-Enhancement-throws-java-lang-VerifyError-JVMVRFY012-for-method-pcClearFields-even-with-version-2-tp7581258p7581267.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message