openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: PostgreSQL 9.1 [Error :current transaction is aborted]
Date Wed, 06 Jun 2012 13:32:50 GMT
Hi Sebastien,
1)  What do you mean it runs without problems?  You still get the exception
right?  What I was interested in were the actual parameter values being
passed in on the "select pg_get_serial_sequence" invocation.  I thought it
might shed some light on why this call wasn't working for you.

2)  Thanks for trying the alternate buildSchema configuration.

3)  Hmmm...  Postgres 8.4 works, huh?  Postgres must have changed something
in the area of sequences that is affecting our runtime.  Thanks for the
debugging efforts.  This may require a change in the Postgres DBDictionary
to allow support for Postgres 9.1.  I also noticed this JIRA (
https://issues.apache.org/jira/browse/OPENJPA-2196) which indicates some
other issue with Sequences and Postgres 9.1.

Kevin

On Wed, Jun 6, 2012 at 7:03 AM, ubiteck <sursini@gmail.com> wrote:

> He Kevin,
> Thanks for your quick reply.
>
> 1) I added the printParameters attribute in my ConnectionFactory property
> to
> test the/ pg_get_serial_sequence/ stored procedure with the parameters
> displayed in the log. It runs without problems.
> 2) I tried to remove the SchemaAction parameters but it has no effects.
> 3) I downgraded Postgress to v8.4 on my ubuntu box to verify and it
> "solves"
> the problem.
>
> I will install the 9.1 version on my Mac and try to debug it.
>
> S├ębastien
>
>
>
>
> --
> View this message in context:
> http://openjpa.208410.n2.nabble.com/PostgreSQL-9-1-Error-current-transaction-is-aborted-tp7580209p7580217.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message