openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: New asm-dependency in OpenJPA 2.2.0?
Date Sun, 26 Feb 2012 19:39:46 GMT
Thanks for the clarification, Dominik.  Your scenario is exactly what I was
thinking you found.  Just needed to be sure.

Good catch on the home page as well...  I just changed this to 2.2.0 as the
latest release.  Although with your finding of the missing ASM lib, a 2.2.1
release might be coming very quickly...  :-)

Thanks again,
Kevin

On Sun, Feb 26, 2012 at 1:16 PM, Dominik Stadler <dominik.stadler@gmx.at>wrote:

> Hi,
>
> yes, I am using the binary zip from
>
> http://www.apache.org/dyn/closer.cgi/openjpa/2.2.0/apache-openjpa-2.2.0-binary.zipand
> not maven.
>
> And in my case the Ant-based build broke where I do build-time enhancement
> of the JPA classes via the Ant-Task org.apache.openjpa.ant.PCEnhancerTask,
> which now requires asm to be found on the classpath.
>
> It's a simple fix to add this in the build.xml and with this all tests run
> fine.
>
> BTW, the main page of OpenJPA currently mentions a version 2.2.1 ("2.2.1 is
> the latest"), I don't think this version is available, right?
>
> Thanks... Dominik.
>
> On Sun, Feb 26, 2012 at 7:40 PM, Kevin Sutter <kwsutter@gmail.com> wrote:
>
> > Hi Dominik,
> > Yes, we did introduce a dependency on ASM for the 2.2.0 release via this
> > JIRA:
> > https://issues.apache.org/jira/browse/OPENJPA-2085
> >
> > It looks like we remembered to update the combined jar
> > (openjpa-all-2.2.0.jar) with the asm class files, but we forgot to
> include
> > it in the lib directory of the apache-openjpa-2.2.0-binary.zip contents.
> > Can you verify that is the location you are referring to?  When you
> > mentioned your compile broke...  Which compile?  The compile of openjpa?
> > Or, the compile of your entity classes?  A maven build of openjpa should
> > pull down the dependency automatically.  Thanks for clarifying.
> >
> > You are right, we probably should have highlighted this new dependency.
> >
> > We might have re-visit the 2.2.0 release in order to include this
> > dependency in the lib directory.  Thanks for bringing this to our
> > attention.
> >
> > Kevin
> >
> > On Sat, Feb 25, 2012 at 2:04 AM, Dominik Stadler <dominik.stadler@gmx.at
> > >wrote:
> >
> > > Hi,
> > >
> > > is there a new dependency on asm introduced with  OpenJPA 2.2.0?
> > >
> > > My compile fails with "java.lang.ClassNotFoundException:
> > > org.objectweb.asm.ClassVisitor" after upgrading.
> > >
> > > Also
> > >
> > >
> >
> http://mail-archives.apache.org/mod_mbox/openjpa-commits/201112.mbox/%3C20111202064303.95653238899C@eris.apache.org%3Eseems
> > > to list a commit which did add such a dependency.
> > >
> > > It would be nice to mention this in the release notes in order to
> prevent
> > > hickups for people upgrading.
> > >
> > > Also shouldn't the asm-.jar files be included in the downloadable
> > binaries?
> > >
> > > Thanks... Dominik.
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message