openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kojak <keit...@gmail.com>
Subject Re: Error: com.ibm.tools.attach.AttachNotSupportedException
Date Mon, 14 Feb 2011 22:07:43 GMT

Rick,

Sorry about the delayed response, but setting "Can-Retransform-Classes:
false" in the manifest file *did* fix the problem.

Apparently, the IBM JRE does not support runtime class re-transformation
(which you probably already know).  Based on this information, I'm assuming
that it would be a best practice to manually run
"org.apache.openjpa.enhance.PCEnhancer" if you are expecting to run with the
IBM JRE so that OpenJPA can take advantage of the enhanced classes for the
IBM JRE, correct?

Also, apparently you can query the JRE to determine it's capabilities via
the 
http://download.oracle.com/javase/1.5.0/docs/guide/jvmti/jvmti.html#GetCapabilities
JVM TI .  This would allow you to determine (at runtime) if the JRE was
capable of class re-transformation; however, I suspect you'd have to write a
JNI interface to get to it which might not be acceptable for a pure Java
solution.


Cheers,
Keith
-- 
View this message in context: http://openjpa.208410.n2.nabble.com/Error-com-ibm-tools-attach-AttachNotSupportedException-tp5989284p6025413.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.

Mime
View raw message