openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laird Nelson <ljnel...@gmail.com>
Subject Quieting the "OpenJPA will not be used" warning message
Date Wed, 19 Jan 2011 16:16:55 GMT
For a whole host of unimportant reasons, we end up getting this message
output by OpenJPA 2.0.0:

INFO: Found persistence provider "org.hibernate.ejb.HibernatePersistence".
OpenJPA will not be used.

(We run unit tests against all the major JPA providers; hence sometimes
other persistence providers show up.  This is expected, and not a cause for
concern for us.)

I have logging throttled down for everything in our production build, but I
cannot stop OpenJPA from spitting out this message.

My logging statement is:

DefaultLevel=ERROR

...with no further modifications.  This correctly shuts OpenJPA up, but I
can't silence the message cited above.  Any help is appreciated.

Best,
Laird

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message