openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Charles <e...@apache.org>
Subject Re: Strange warnings about query parameters
Date Tue, 14 Sep 2010 19:33:07 GMT
  Hi,
We also have these warning messages in apache james trunk project (in 
unit test and in spring container).
The Query works just fine.

8923  WARN   [main] openjpa.Runtime - Supplied user parameters "[domain, user]" do not match
expected parameters "[]" for the prepared query "PreparedQuery: [SELECT vut FROM JamesVirtualUserTable
vut WHERE (vut.user LIKE :use
  vut.domain DESC] -->  [SELECT t0.DOMAIN, t0.USER0, t0.TARGET_ADDRESS FROM VIRTUALUSERTABLE
t0 WHERE ((t0.USER0 LIKE ? ESCAPE '\' OR t0.USER0 = ?) AND (t0.DOMAIN LIKE ? ESCAPE '\' OR
t0.DOMAIN = ?)) ORDER BY t0.DOMAIN DESC]".
8939  TRACE  [main] openjpa.jdbc.SQL -<t 958922509, conn 1153873934>  executing prepstmnt
563165009

Should we worry about this ?
Is there a JIRA we can refer to ?

Tks,
Eric


On 18/08/2010 10:24, Harald Wellmann wrote:
> The funny thing is, it does not bomb. I turned on DEBUG logging and looked at
> the generated SQL query which is ok. I also manually ran the SQL query to
> verify the results.
>
> All this happens in the context of a web app running on Glassfish 3.0.1, and
> the problem is reproducible always within this application.
>
> I tried to isolate the effect by running the same JPQL query in my unit test
> environment where the same JPA model is used in a Java SE context, but in
> that case the warning does not occur.
>
> Let me know if there's anything I can do to pinpoint the problem.
>
> Best regards,
> Harald
>


Mime
View raw message