openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID (ATTSI)" <dk0...@att.com>
Subject RE: Schema version problem upgrading to JPA 2.0
Date Thu, 20 May 2010 01:57:51 GMT
> -----Original Message-----
> From: C N Davies [mailto:cnd@cndavies.com]
> Sent: Wednesday, May 19, 2010 6:52 PM
> To: users@openjpa.apache.org
> Subject: RE: Schema version problem upgrading to JPA 2.0
> 
> I had some issues like this when I switched, it ended up being that I
> had
> class files that had been compiled under 1.2.x still in my deployment
> directory. I blew the directory away and rebuilt and off I went.
> 
> Chris

Thanks, but that's not it.  I'm doing a "clean" before every build.
Considering the error I get at build/enhancement time is a schema
validation error on the orm.xml file, I don't see how that could be
possibly be related to leftover class files.

> -----Original Message-----
> From: KARR, DAVID (ATTSI) [mailto:dk068x@att.com]
> Sent: Thursday, 20 May 2010 11:31 AM
> To: users@openjpa.apache.org
> Subject: Schema version problem upgrading to JPA 2.0
> 
> I think I noticed some talk about this before, but I can't find it in
> the archives now.
> 
> I tried to upgrade to version 2.0.0 today.  The upgrade with no
changes
> worked fine.  Now I'm trying to modify it to use the small number of
> 2.0
> features that I'm attempting to use.
> 
> When I changed the "schemaLocation" attribute to point to the 2.0 xsd
> (I'm really surprised the namespace didn't change), then Eclipse
> complained that I had to change the "version" attribute also, which I
> did (to 2.0).  I then added several "order-column" elements where I
was
> previously using the OpenJPA OrderColumn annotation.  When I attempted
> to build this, I got schema validation errors, claiming that there was
> no "order-column" element (even though Eclipse validates this).  If I
> temporarily changed the "version" attribute value back to "1.0", then
I
> could get through that part of the build, even though Eclipse is now
> complaining.  I haven't attempted to run the app in this state.
> 
> What am I missing?


Mime
View raw message