openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID (ATTSI)" <dk0...@att.com>
Subject Does anyone know if <OPENJPA-384> (OpenJPA 1.x on WebLogic 10 classloader conflict) works better with OpenJPA 2.x?
Date Tue, 11 May 2010 17:20:49 GMT
A while ago I built a prototype application using OpenJPA 1.2.2.  I
deployed it to WebLogic 10.3.2.  It works fine there.  It's been in
prototype status for a long time now, but we may move to deploy it for
real very soon.  One issue we have is that our existing WebLogic
instances are using an older version of WebLogic, version 10MP1.  I
decided I should at least determine whether the app can run in that
environment.

When I deploy it, I see errors like the following:

  java.lang.ClassCastException: weblogic.kodo.WebLogicLogFactory

When I googled this, I found
<https://issues.apache.org/jira/browse/OPENJPA-384>.  This is ancient
history, but does anyone know if this problem still happens with the
OpenJPA 2.x release?  I would expect it would, but I'm just gathering
data points.

Mime
View raw message