openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ljnelson <ljnel...@gmail.com>
Subject Re: NoClassDefFoundError in JavaSE environment
Date Thu, 13 May 2010 17:03:31 GMT

Suppose hypothetically that weren't an option?  :-)

I have a parameterized JUnit test case that loops over persistence units.
I've made each such unit declare an explicit provider, one from each of the
Big Three (you guys, that funny project that starts with "H" and rhymes with
"fiber, mate!", and the other one that has too many "l"s and "p"s in it).
For each unit, the test asks for a new EntityManagerFactory, and from it a
new EntityManager.

So I don't have the ability to enhance classes for each run.

Best,
Laird

On Thu, May 13, 2010 at 12:50 PM, Rick Curtis [via OpenJPA] <
ml-node+5047019-539322061-210534@n2.nabble.com<ml-node%2B5047019-539322061-210534@n2.nabble.com>
> wrote:

> I'd suggest trying the OpenJPA javaagent just to rule out any problems that
> might be happening due to the RuntimeUnenhancedClasses.
>
>
>
> ------------------------------
>  View message @
> http://openjpa.208410.n2.nabble.com/NoClassDefFoundError-in-JavaSE-environment-tp5043127p5047019.html
> To start a new topic under OpenJPA Users, email
> ml-node+208411-553807638-210534@n2.nabble.com<ml-node%2B208411-553807638-210534@n2.nabble.com>
> To unsubscribe from OpenJPA Users, click here< (link removed) =>.
>
>
>

-- 
View this message in context: http://openjpa.208410.n2.nabble.com/NoClassDefFoundError-in-JavaSE-environment-tp5043127p5047083.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message