openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vásáry, Dániel <vas...@elgekko.net>
Subject Re: Entity data missing in enhanced mode
Date Wed, 21 Apr 2010 21:09:41 GMT
Wich OpenJPA version you used? I tried 1.2.2 and 1.2.3.
I am newbie on JAVA and OpenJPA too.
Can some system misconfiguration cause something like that?

2010/4/21 Rick Curtis <curtisr7@gmail.com>

> Hmm, I'm still not sure what the problem is that you are reporting. I ran
> your same test on HSQLDB and it worked fine for me. Sounds like I still may
> be missing something?
>
> --
> Thanks,
> Rick
>
> On Wed, Apr 21, 2010 at 1:46 PM, Vásáry, Dániel <vasary@elgekko.net>
> wrote:
>
> >
> > Yes, the data is properly persisted.
> > I have SQL trace turned on, no errors.
> > I have only one strange debug message: "No cache marshaller found for id
> > org.apache.openjpa.conf.MetaDataCacheMaintenance."
> > Log is attached.
> >
> >
> >
> >
> >
> >
> > propertiesMap.put("openjpa.Log", "SQL=trace");
> >>
> >> Are there any warnings or other errors logged?
> >>
> >> --
> >> Thanks,
> >> Rick
> >>
> >> On Wed, Apr 21, 2010 at 1:19 PM, Vásáry, Dániel <vasary@elgekko.net>
> >> wrote:
> >>
> >> > Thanks for quick reply.
> >> > I attached one of the Entities, and unit test.
> >> >
> >> > 2010/4/21 Rick Curtis <curtisr7@gmail.com>
> >> >
> >> > Can you post some more information? A small unit test would be nice...
> >> but
> >> >> a
> >> >> nice place to start would be by posting the given Entity.
> >> >>
> >> >> --
> >> >> Thanks,
> >> >> Rick
> >> >>
> >> >>
> >> >> On Wed, Apr 21, 2010 at 12:03 PM, Vásáry, Dániel <vasary@elgekko.net
> >
> >> >> wrote:
> >> >>
> >> >> > Hi,
> >> >> > I'm using OpenJPA 1.2.2 under JavaEE JPA project in Eclipse
> Galileo.
> >> >> > After adding Bytecode enhancement, named query returns only partial
> >> >> data.
> >> >> > Persisted object looks fine, has all fields filled with proper
> data.
> >> >> >
> >> >> > But if i search for that object with named query or with
> >> >> > EntityManagers.find,
> >> >> > returned entity has 0 value in ID field, and the other fields
are
> >> empty
> >> >> > too,
> >> >> > except String fields.
> >> >> > I need all field's data from entity, for some post processing
> >> purposes.
> >> >> >
> >> >> > Can anybody help, how to retrive whole data?
> >> >> > thanks
> >> >> >
> >> >>
> >> >
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message