openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Polliard <tho...@polliard.com>
Subject Confused about why Im getting this error
Date Mon, 18 Jan 2010 01:15:02 GMT
Doing an example trying to learn OpenJPA and JPA I ran into a strange problem.

java.lang.ClassNotFoundException: com.arjuna.jta.JTA_TransactionManager
java.lang.ClassNotFoundException: com.bluestone.jta.SaTransactionManagerFactory
java.lang.ClassNotFoundException: org.openejb.OpenEJB
java.lang.ClassNotFoundException: com.sun.jts.jta.TransactionManagerImpl
java.lang.ClassNotFoundException: com.inprise.visitransact.jta.TransactionManagerImpl


I am not using "Any of these yet for some reason, I am getting this error"

The problem is Only when I run the main program:

Main.java
package com.trukoda.examples.jpa;

import javax.persistence.EntityManager;
import javax.persistence.EntityManagerFactory;
import javax.persistence.Persistence;

public class Main {
	public static void main(String[] args) {
		EntityManagerFactory factory = Persistence.createEntityManagerFactory("ExampleJPA");
		Account user1 = new Account("polliard");
		Account user2 = new Account("mcclung");
		
		Host host1 = new Host("uranium");
		Host host2 = new Host("thorium");
		
		EntityManager em = factory.createEntityManager();
		
		em.getTransaction().begin();
		em.persist(host1);
		em.persist(host2);
		em.getTransaction().commit();
	}
}

Any idea why this this would causes classes I am not referencing from being loaded.

I am including the following in my classpath:

.:/Users/polliard/Library/Java/Derby/10.5.3.0/derby.jar:/Users/polliard/Library/Java/Openjpa/2.0-M3/openjpa-all-2.0.0-M3.jar

The two accounts (Account and Host) are basic Entities and the database gets created without
issue using the mappingtool.

Thanks for any assistance,

Thomas
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message