openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID (ATTCINW)" <dk0...@att.com>
Subject RE: Using latest OpenJPA in WebLogic 10
Date Wed, 02 Dec 2009 06:30:03 GMT
> -----Original Message-----
> From: Ravi Palacherla [mailto:ravi.palacherla@oracle.com]
> Sent: Tuesday, December 01, 2009 7:00 PM
> To: users@openjpa.apache.org
> Subject: RE: Using latest OpenJPA in WebLogic 10
> 
> Hi David,
> 
> You can use Filtering Classloader that weblogic server supports.

Yes, using the "prefer-application-packages" element in the
weblogic-application.xml file.  I'm familiar with that.  The problem is,
I know that this doesn't work 100% of the time.  Has anyone successfully
used this with OpenJPA to avoid using the one provided by WebLogic?

> -----Original Message-----
> From: KARR, DAVID (ATTCINW) [mailto:dk068x@att.com]
> Sent: Tuesday, December 01, 2009 6:41 PM
> To: users@openjpa.apache.org
> Subject: Using latest OpenJPA in WebLogic 10
> 
> I'm looking at using the latest GA release of OpenJPA, v1.2.1, on
> WebLogic 10 (not 10.3), in a webapp, not as an ejb-jar or EAR.
> Apparently WebLogic 10 already includes a version of OpenJPA, but
> certainly an older version.  Will I have any trouble using the latest
> OpenJPA just in my webapp?  Is there something I need to do to prevent
> conflicts?  I'm familiar with "prefer-web-inf-classes", but I'm not
> sure
> whether that will help.

Mime
View raw message