openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: Using latest OpenJPA in IBM WebSphere v7
Date Wed, 02 Dec 2009 14:15:50 GMT
Hi Michael,
WebSphere v7 can utilize any version of OpenJPA that is compliant with the
JPA 1.0 specification.  The OpenJPA 1.2.x branch is used to service the
version of OpenJPA that ships with WebSphere 7.  If you are interested in
using the OpenJPA 1.3.x branch on WebSphere 7, you should be able to follow
the instructions in the InfoCenter [1].  If you are having problems with the
approaches outlined in the documentation, please reply back and let me know
so that we can these resolved.  Thanks.

Very briefly, the general approach is to load the alternate OpenJPA provider
as a shared library and then use the isolated classloader setting for the
use of this shared library.  More details are in the article, if your
environment or requirements are slightly different.

Using the OpenJPA 2.0.x branch in WebSphere v7 is a bit more tricky.  Due to
the new versions of the Persistence APIs and XSDs, upgrading to the JPA 2.0
level of functionality required a bit more integration.  But, if you are
interested in this approach, I would suggest our Alpha [2] to get you
started.  This would lay the ground work.  Currently, the Alpha is based off
of the M3 driver for 2.0.x.  If you wanted to try a newer driver on top of
the Alpha, the same type of procedure as documented in the InfoCenter *
should* work, but I don't believe anyone has tried this yet...  :-)

HTH,
Kevin

[1]
http://publib.boulder.ibm.com/infocenter/wasinfo/v7r0/topic/com.ibm.websphere.nd.multiplatform.doc/info/ae/ae/tejb_jpa3rdparty.html
[2]
https://www14.software.ibm.com/iwm/web/cc/earlyprograms/websphere/wsasjpaoa/

On Wed, Dec 2, 2009 at 5:12 AM, Michael Vorburger <
mvorburger@odyssey-group.com> wrote:

> Same question as in the previous/parallel thread "RE: Using latest
> OpenJPA in WebLogic 10", but for IBM WebSphere (v7 only) : Do any of you
> here know how to "officially" get WAS to accept a more recent version
> (or simply a specific fixed version, instead of the one it comes with)
> of an OpenJPA JAR?  Just placing one in the EAR seems to, obviously, not
> work.
>
> Just wondering.
>
> ____________________________________________________________
>
> • This email and any files transmitted with it are CONFIDENTIAL and
> intended
>  solely for the use of the individual or entity to which they are
> addressed.
> • Any unauthorized copying, disclosure, or distribution of the material
> within
>  this email is strictly forbidden.
> • Any views or opinions presented within this e-mail are solely those of
> the
>  author and do not necessarily represent those of Odyssey Financial
> Technologies SA unless otherwise specifically stated.
> • An electronic message is not binding on its sender. Any message referring
> to
>  a binding engagement must be confirmed in writing and duly signed.
> • If you have received this email in error, please notify the sender
> immediately
>  and delete the original.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message