openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From coloradoflyer <open...@parallelsw.com>
Subject Re: null values not updating
Date Thu, 16 Jul 2009 05:06:27 GMT

I've made the unit test as small as I possibly could think where it would
still make sense.  I tried this out in hsql and got the same results, so the
config's have the postgres values commented out and this should use hsql for
its database.  
I also noticed that openejb-3.1 ships with openjpa-1.1 so I just used all of
the libraries shipped with openejb-3.1 with the same result.

The example has 4 basic java files, and the test case.  There is the EJB
Interface (I called it a DAO), and the implementation for it.  There is also
the Entity interface and implementation.  Then the test case which, if it
passes the problem does not exist.

src/com/openrangetest/daos/AgeRangeDAO.java
src/com/openrangetest/daos/impl/AgeRangeDAOImpl.java

src/com/openrangetest/entities/Range.java
src/com/openrangetest/entities/impl/AgeRangeImpl.java

src/com/openrangetest/tests/OpenEJBTestCase.java

please let me know if you see anything in here that looks wrong.  I am
thinking the changes will be needed somewhere in the conf/openejb.xml file
or in the persistence.xml file...

thanks in advance,
-chris

Daryl Stultz wrote:
> 
> On Sat, Jul 11, 2009 at 2:05 AM, coloradoflyer
> <openjpa@parallelsw.com>wrote:
> 
>>
>> Hi Daryl,
>>
>> I added in a 'version' colum to the table, and get/set methods for
>> Version
>> and annotated it @Version
>> ...
>> With these changes, the problem did not change.
> 
> 
> Given that I solved my null problems without using @Version, I'm not
> surprised. Can you provide a unit test that exposes the problem? I don't
> think we need to be able to run it, but show enough detail to see what's
> happening. I'm no OpenJPA expert but I think the problem might occur be
> before you set the null value.
> 
> -- 
> Daryl Stultz
> _____________________________________
> 6 Degrees Software and Consulting, Inc.
> http://www.6degrees.com
> mailto:daryl@6degrees.com
> 
> 
http://n2.nabble.com/file/n3267404/rangetest.jar rangetest.jar 
-- 
View this message in context: http://n2.nabble.com/null-values-not-updating-tp3224059p3267404.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.

Mime
View raw message