openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Curtis <curti...@gmail.com>
Subject Re: enhancement problem
Date Tue, 23 Jun 2009 11:36:31 GMT

László -

OpenJPA does support running with unenhanced classes but it's not
recommended. There are a number of known issues and there have been many
discussions on disabling the support for running with unenhanced classes. I
would suggest either using the -javaagent or buildtime enhancement to
enhance your entities [1].

-Rick

[1] http://openjpa.apache.org/entity-enhancement.html


László Hornyák wrote:
> 
> Hi!
> 
> I am using OpenJPA 1.2.1 on jdk 1.6 and I get this exception when running
> a
> JPA-QL.
> I have the class listed in persistence.xml. I do not run enhancer, but
> OpenJPA supports unenhanced classes on java 1.6.
> 'foo.Bar' is an abstract class and it is the superclass of most of my
> persistent beans.
> Also, the strange thing is that I can persist the instances of the derived
> classes, but I still get this exception when I try to run a query.
> 
> .....
> 
> 

-- 
View this message in context: http://n2.nabble.com/enhancement-problem-tp3140721p3141920.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message