openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B.L. Zeebub" <roger.var...@googlemail.com>
Subject Re: [Newbie] OPenJPA (1.2.1) Enhancement woes
Date Fri, 19 Jun 2009 09:44:03 GMT



David Beer-2 wrote:
> 
> Hi
> 
> Just as an extra here is my ant task in NetBeans, I also override the
> -post-jar target as well.
> 
> <target name="-pre-jar">
>         <taskdef name="openjpac"
> classname="org.apache.openjpa.ant.PCEnhancerTask" > <classpath>
>                 <pathelement location="${build.classes.dir}"/>
>                 <pathelement path="${javac.classpath}"/>
>             </classpath>
>         </taskdef>
>         <echo message="openjpa enhancer started"/>
>         <openjpac>
>             <config propertiesFile="openjpa-dev.xml"/>
>             <classpath>
>                 <pathelement location="${build.classes.dir}"/>
>                 <pathelement path="${javac.classpath}"/>
>             </classpath>
>             <fileset dir="${build.classes.dir}">
>                 <include name="**/*.class"/>
>                 <exclude name="**/DatabaseConnection.class"/>
>                 <exclude name="**/DatabaseFunctions.class"/>
>             </fileset> 
>         </openjpac>
>         <echo message="openjpa enhancer finished"/>
>     </target>
> 
> 

David, you are a scholar and a gentleman sir! I copied your ant task into my
build.xml and lo and behold everything works perfectly now. Thanks very much
to everyone for their help.

Regards


-- 
View this message in context: http://n2.nabble.com/-Newbie--OPenJPA-%281.2.1%29-Enhancement-woes-tp3085661p3118728.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message