openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Naomi-...@gmx.de
Subject Re: Runtime Enhancement: Problems with Ant Task in Eclipse
Date Mon, 18 May 2009 15:08:42 GMT
I tried to invoke it after a build, but the problem is that it is not invoked if I use CTRL
+ B or the corresponding menu items.

I just tried to delete all content from my binary folder and then starting a build, but this
did not work either. Honestly, there are also no classes created. I can only generate classes
by using the "Clean" command (that is why I invoked the Ant task after a "Clean").

For the case it could really be an Eclipse problem (actually seems so...): I am using Ganymede
Eclipse 3.4.2 

Thank you again for your answers :)

-------- Original-Nachricht --------
> Datum: Mon, 18 May 2009 07:48:34 -0700 (PDT)
> Von: Rick Curtis <curtisr7@gmail.com>
> An: users@openjpa.apache.org
> Betreff: Re: Runtime Enhancement: Problems with Ant Task in Eclipse

> 
> -Naomi
> I don't think you want to invoke the script after a "Clean", my vauge
> understanding is that would be used to clean up resources that Eclipse
> wouldn't have cleaned up as part of a normal clean. In the blog posting,
> it
> shows to invoke the enhancer script on a manual and auto build, have you
> tried that yet? 
> 
> -Rick
> 
> 
> Naomi-san wrote:
> > 
> > Hi Rick,
> > 
> > I also had that thought, but the message lists all of my entities, so I
> > think they all have not been enhanced.
> > 
> > I oriented on the following tutorial for creating and invoking the build
> > script:
> > 
> >
> http://webspherepersistence.blogspot.com/2009/04/openjpa-enhancement-eclipse-builder.html
> > 
> > I edited the XML to avoid setting and checking the arguments and
> > additionally added my entities to the build path.
> > 
> > I also invoked the script on Eclipse's "Clean" process (does not make
> > sense, I think, does it?) and I started it "manually" (right click on
> the
> > enhance task and choosing "run as" - "Ant build").
> > 
> > -Naomi
> > 
> > -------- Original-Nachricht --------
> >> Datum: Mon, 18 May 2009 07:06:16 -0700 (PDT)
> >> Von: Rick Curtis <curtisr7@gmail.com>
> >> An: users@openjpa.apache.org
> >> Betreff: Re: Runtime Enhancement: Problems with Ant Task in Eclipse
> > 
> >> 
> >> Is it possible that only a portion of your Entities are being enhanced
> by
> >> the
> >> build script? How are you invoking the ant build script?
> >> 
> >> -Rick
> >> -- 
> >> View this message in context:
> >>
> http://n2.nabble.com/Runtime-Enhancement%3A-Problems-with-Ant-Task-in-Eclipse-tp2932839p2933295.html
> >> Sent from the OpenJPA Users mailing list archive at Nabble.com.
> > 
> > -- 
> > Neu: GMX FreeDSL Komplettanschluss mit DSL 6.000 Flatrate +
> > Telefonanschluss für nur 17,95 Euro/mtl.!*
> > http://dslspecial.gmx.de/freedsl-surfflat/?ac=OM.AD.PD003K11308T4569a
> > 
> > 
> 
> -- 
> View this message in context:
> http://n2.nabble.com/Runtime-Enhancement%3A-Problems-with-Ant-Task-in-Eclipse-tp2932839p2933532.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.

-- 
Neu: GMX FreeDSL Komplettanschluss mit DSL 6.000 Flatrate + Telefonanschluss für nur 17,95
Euro/mtl.!* http://dslspecial.gmx.de/freedsl-surfflat/?ac=OM.AD.PD003K11308T4569a

Mime
View raw message