openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Curtis <curti...@gmail.com>
Subject Re: Enhancing entities: getting desperate
Date Wed, 20 May 2009 13:10:20 GMT

It would appear that the class org.w3c.dom.svg.SVGDocument isn't on the
classpath when you run the enhancer.

-Rick



Prodoc wrote:
> 
> Fixed now. A simple later calling of the enhance target did the trick.
> I'm now back at the 'NoClassDefFoundError' error. Any idea what the cause
> of this could be?
> 
> Here's the complete error:
> -------------------------------------------------------------------------------------------------
> enhance:
> java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
>       at java.lang.Class.getDeclaredMethods0(Native Method)
>       at java.lang.Class.privateGetDeclaredMethods(Class.java:2427)
>       at java.lang.Class.getDeclaredMethods(Class.java:1791)
>       at
> org.apache.openjpa.lib.util.J2DoPrivHelper$9.run(J2DoPrivHelper.java:305)
>       at java.security.AccessController.doPrivileged(Native Method)
>   .....
> Caused by: java.lang.ClassNotFoundException: org.w3c.dom.svg.SVGDocument
>       at
> org.apache.openjpa.lib.util.TemporaryClassLoader.loadClass(TemporaryClassLoader.java:64)
>       at
> org.apache.openjpa.lib.util.TemporaryClassLoader.loadClass(TemporaryClassLoader.java:44)
>       at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
>       ... 45 more
> ...
> This only pops up because of the enhance procedure.
> 
> Yours,
> 
> Age
> 

-- 
View this message in context: http://n2.nabble.com/Enhancing-entities%3A-getting-desperate-tp2937944p2946034.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message