openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ashishpaliwal <ashishpaliwal....@gmail.com>
Subject Re: Files in package org.apache.openjpa.kernel.jpql.
Date Wed, 29 Apr 2009 03:36:41 GMT

Hi,

Thanks people but some how I am still not able to run examples. I took
fresh code and build id succesfully using maven. After this I included
project in eclipse. What was happening was when I tried to run
hellojpa example eclipse was deleting the target folder and creating
again(probably building the code) but it was not creating the complete
files under classes\org\apache\openjpa\kernel\jpql package that were
created by mavne like TreeConstant. So I build it again using maven,
saved the classes folder on Desktop and added path to this
Desktop/classes in my classpath. After this all the errors were
removed after refreshing but on running it wasn't able to create the
factory in very first line of hellojpa example.
I am really not able to follow firstly why eclipse is not generating
the complete classs and secondly why I am not getting factory created.
I din't do any changes in persistance.xml or build.xml files. It will
be of great help if someone can throw some light on my problem.

thanks

On Tue, Apr 28, 2009 at 8:53 PM, Kevin Sutter (via Nabble)
<ml-user+17993-75047603@n2.nabble.com> wrote:
> Hi Ashish,
> These "extra" files are generated as part of our JJTree processing.  It
> sounds like you successfully built the OpenJPA project using maven, so
> that's good.  Within Eclipse, you need to tell Eclipse about these other
> generated files to complete your build.  If you look under
> ../target/generated-sources/, you'll find these missing files.  You'll need
> to add this directory to your build configuration within Eclipse.
>
> Kevin
>
> On Tue, Apr 28, 2009 at 10:01 AM, ashish paliwal <
> ashishpaliwal.bit@...> wrote:
>
>> Hi,
>>
>> I downloaded the latest code using -- svn co
>> http://svn.apache.org/repos/asf/openjpa/trunk mydir and then build it
>> successfully using maven. After importing all the source into eclipse
>> I was encountering few errors in package
>> /org/apache/openjpa/kernel/jpql. For instance in class
>> JPQLExpressionBuilder it couldn't find JPQLTreeConstants, and there
>> were many others. I then downloaded the nightly build
>> apache-openjpa-2.0.0-SNAPSHOT-binary.zip and in this in
>> openjpa-2.0.0-SNAPSHOT.jar file inside the package
>> org.apache.openjpa.kernel.jpql there were more files(e.g
>> JPQLTreeConstants.class) than what I had after downloading code using
>> svn.
>> Now I am not able to understand where are these files in my code that
>> I have taken from svn. Am I looking in some wrong package or do I need
>> to include some jar in my build path in eclipse? It will be of great
>> help to me if someone can throw some light on this.
>>
>> Thanks and regards
>>
>> Ashish Paliwal
>> Mobile : 9305128367
>> IIT Kanpur
>> India
>>
>
>
> ________________________________
> View message @
> http://n2.nabble.com/Files-in-package-org.apache.openjpa.kernel.jpql.-tp2734002p2734132.html
> To start a new topic under OpenJPA Users, email
> ml-node+208411-1807955471@n2.nabble.com
> To unsubscribe from OpenJPA Users, click here.
>



-- 
Ashish Paliwal
Mobile : 9305128367
IIT Kanpur
India

-- 
View this message in context: http://n2.nabble.com/Files-in-package-org.apache.openjpa.kernel.jpql.-tp2734002p2738437.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message