openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: It is getting out of hands!!!
Date Wed, 18 Mar 2009 19:14:16 GMT
Andrei,
I'm sorry you are experiencing issues with your scenario.  But, we will
probably need additional information to help decipher the problem.  We have
many, many testcases that use @Version in the Entities.  And, 95% of our
testing is with enhanced Entities (either statically or dynamically).  So,
my guess is that there's something unique with your particular scenario.

In the previous string of notes, you had provided a snippet of code.  Can
you provide a failing example or testcase that demonstrates the problem?  We
just need something more to go off to determine the source of the problem.

Thanks,
Kevin

On Tue, Mar 17, 2009 at 11:59 AM, Andrei Tchijov <andrei@tchijov.com> wrote:

>
> Somehow DB got into this situation again (identical stack traces).  I
> end-up
> removing (commenting out) @Version field from PSLBase class and now it
> works
> (without any changes to DB).
>
> I think it points quite conclusively that something is not right with the
> way @Version field influence enhanced code.  I will be more then happy to
> admit that I am doing something wrong, but I would like to know what
> exactly
> I am doing wrong.
>
>
> Andrei
> --
> View this message in context:
> http://n2.nabble.com/Strange-%22ClassCast%22-Exception-%28and-even-stranger-way-it-disappear%29-tp2491173p2492567.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message