openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Curtis <curti...@gmail.com>
Subject Re: has not been enhanced
Date Wed, 25 Mar 2009 01:59:04 GMT

Can we get some more info? Your persistence.xml file along with the actual error message would
be a good start.

-Rick


I'm working successfully on my first jpa project,
using netbeans, maven and openjpa.

Now I added another entity class by applying the generator from the pull
down menu of a package "New/Entity Classes from Database ..."

It generated two entity classes because the key has multiple colums:
Entity and EntityPK.

When I built the project again I get the error:

"The type "class EntityPK" has not been enhanced."

And the build stops.

I looked in the documentation for "enhancement" and found it to be an
important subject but was not able to understand why a class shall be
enhanced in order for the project to get built.

Before I added this entity to the other 5 - one with a primary key class
as well - I didn't had this problem and everything worked smooth. Now I
got stuck.

What shall I look into to overcome this problem?

Rolf

p.s. When I ran the maven goal openjpa:enhance an exception occurs while
parsing a non-entity class, telling me that a class can not be found
that I provide at runtime. Honestly, I do not know what I was doing here.




-- 
View this message in context: http://n2.nabble.com/has-not-been-enhanced-tp2529973p2530260.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message