openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goodenough <david.goodeno...@btconnect.com>
Subject Re: maven-openjpa-plugin problem
Date Thu, 12 Feb 2009 14:21:19 GMT
On Thursday 12 February 2009, Kevin Sutter wrote:
> David,
> I totally agree that enhancing the JPA POJOs is a desired operation.  I was
> referring to the maven plugin itself.  Is this tool worthwhile to support?
> It sounds like it could help the build time processing for OpenJPA
> enhancement.
>
> Kevin

It would certainly be useful to me, and by the sound of others on this thread
to them too, so yes please if you could find a way to either adopt it or 
persuade its authors to keep it up to date that would be great.

David
>
> On Thu, Feb 12, 2009 at 4:04 AM, David Goodenough <
>
> david.goodenough@btconnect.com> wrote:
> > On Wednesday 11 February 2009, Kevin Sutter wrote:
> > > Is this worth "enhancing" (pardon the pun)?  Seriously, is this maven
> > > plugin worth supporting?  Or, possibly bringing into our svn?
> >
> > Well yes there is a good reason to enhance.
> >
> > If you are using BeanBindings (and I guess that the other Bean Binding
> > machanisms have the same problem) it gets very confused if there are two
> > versions of the same class around, the one that is bound and the one that
> > gets delivered with the data.  The only way I found to get binding to
> > work correctly was to enhance the JPA POJOs.
> >
> > This has been discussed on several occasions on this forum (I initiated
> > one of the threads, and I was then pointed at other threads).
> >
> > David
> >
> > > On Wed, Feb 11, 2009 at 4:08 PM, Rick Curtis <curtisr7@gmail.com> wrote:
> > > > Dave -
> > > > I struggled with this very problem yesterday and never did get it to
> >
> > work
> >
> > > > properly. I ended up using the ant-run plugin to invoke the OpenJPA
> > > > enhancer
> > > > task.
> > > >
> > > > Rick
> > > >
> > > > David Goodenough-3 wrote:
> > > > > I am trying to the the OpenJPA plugin so that I can use the static
> > > > > enhancer as
> > > > > part of my Maven2 build.  But when I run it it seems to be drawing
> > > > > in
> > > >
> > > > very
> > > >
> > > > > old
> > > > > versions of OpenJPA.
> > > > >
> > > > > Is this plugin useable with current versions of OpenJPA, and if not
> >
> > is
> >
> > > > > there
> > > > > a newer version of the mojo around anywhere?
> > > > >
> > > > > David
> > > >
> > > > --
> > > > View this message in context:
> >
> > http://n2.nabble.com/maven-openjpa-plugin-problem-tp2311703p2311733.html
> >
> > > > Sent from the OpenJPA Users mailing list archive at Nabble.com.



Mime
View raw message