openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pinaki Poddar <ppod...@apache.org>
Subject Re: Issue with FetchAttribute recursionDepth
Date Wed, 18 Feb 2009 21:27:14 GMT

Hi,

> Would it be possible to get this fix in a 1.2.x release? 
Did you observer the error in 1.2x? I wrongly thought that it is recent
regression. I will then consider this issue resolved on trunk i.e. 2.0.x
stream.

> Would it be possible to get this fix in a 1.2.x release? 
Unlikely from both logistic and complexity perspectives. 


> Thanks again for helping to resolve this issue.
You are welcome.





Brian Dellert wrote:
> 
> Pinaki,
> 
> I tried this with a nightly 2.0.0-SNAPSHOT build and things are working
> correctly.  Would it be possible to get this fix in a 1.2.x release?  Or
> should it be assumed that this will only be resolved in 2.0.0?  Thanks
> again for helping to resolve this issue.
> 
> - Brian
> 
> 
> Pinaki Poddar wrote:
>> 
>> Hi Brian,
>>    The test case attached with OPENJPA-911 (you got the important JIRA
>> number:) runs on trunk. I did not see any assert() commented out -- so am
>> assuming that it meets expected behavior. OpenJPA issued 4 SQL to fetch
>> the  entire graph before and after delete.
>>   If it possible for you, run it against the latest nightly builds. If
>> the test was failing with an earlier nightly build version, I may be
>> responsible. Some changes I have made to reuse SQL for repeated JPQL
>> execution *may* have caused it as your test does execute the same JPQL
>> twice. With the recent changes, the second execution of JPQL will bypass
>> the major code path and directly execute cached SQL.
>> 
>> 
> 
> 

-- 
View this message in context: http://n2.nabble.com/Issue-with-FetchAttribute-recursionDepth-tp2260751p2349458.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message