openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pinaki Poddar <ppod...@apache.org>
Subject Re: Query using select max( @Version_field ) fails - why?
Date Wed, 26 Nov 2008 17:05:16 GMT

Hi,
  
  1. TypeEntity class has annotated two fields namely 'id' and 'version' as
@Id. That makes a composite key but no identity class has been declared. Bit
surprised that no error had been flagged.
  2. 'version' field is marked as both @Id and @Version. Is that intended?
  3. After omiiting @Id annotation from @Version field, the query executed
without error with OpenJPA version later than openjpa-1.0.2.


-- 
View this message in context: http://n2.nabble.com/Query-using-select-max%28-%40Version_field-%29-fails---why--tp1580252p1581623.html
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message