openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick" <michael.d.d...@gmail.com>
Subject Re: OpenJPA Jar requirements
Date Fri, 17 Oct 2008 14:15:52 GMT
Hi Marc,

I agree that we should document it on the website. The minimal list of
required jars is included in the apache-openjpa-x.y.y-binary.zip in the lib
directory.

In 1.3.0-SNAPSHOT (versions may be different for 1.0.x).

serp-1.13.1.jar
commons-lang-2.1.jar
commons-collections-3.2.jar
commons-pool-1.3.jar
geronimo-jta_1.1_spec-1.1.jar*
geronimo-jpa_3.0_spec-1.0.jar*

* These are needed for JSE, in JEE the application server will typically
prefer their own copy.

Derby is also included, but as you mentioned you don't need that if you use
a different database.

Commons-pool is used for the TCPRemoteCommitProvider, so if you aren't using
remote commit providers it would also be optional (from what I can tell).

hth

-mike


On Thu, Oct 16, 2008 at 8:37 AM, Marc Logemann <ml@logemann.org> wrote:

> Hi,
>
> is there somewhere a list of the needed JARs for a deployment? I am
> assuming that i dont need the derby jar when using "normal" databases and i
> am wondering if i need commons-pool ....
>
> I scanned the docs but there is no page indicating what jars do what and if
> they are needed. BTW i like that OpenJPA is that streamlined regarding jars.
> I remember Kodo being more demanding when it comes to 3rd party stuff....
>
> Marc
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message