openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gareth Davies" <Gareth.Dav...@msoft.co.uk>
Subject Problem with openjpa enhancer - using runtime enhancement
Date Wed, 16 Jul 2008 09:34:23 GMT
Hi

Openjpa 1.1.0

I am having a problem with runtime enhancement on my persistent
entities.  Runtime enhancement completes during my test phase using the
openejb 3.0 javaagent, but when the unit tests run I have problems
relating to merges using the entityManager.  The id field does not seem
to be generated correctly it seems to be giving it a 0 value rather than
the next available id and it doesn't actually seem to be inserting into
the database.  I have tried the same build process using build time
enhancement and all the tests pass (I would use build time enhancement
but having tried it during the build with the openjpa-maven-plugin,
which seems to only support openjpa 0.9.6, my command line is too long
~16100 characters and Windows limit is 8192, I had to resort to a batch
file).  

Has anyone else had any issues with this, or are there difference
between runtime and build time enhancement that are causing these
failures.

Also if anyone has any ideas about getting the build time enhancement to
run as part of a maven build without using the openjpa-maven-plugin that
would be great.

Thanks

Gareth Davies

Mime
View raw message