openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Nelson" <eric.nel...@unishippers.com>
Subject Getting error: java.lang.NoSuchFieldError: brokerPlugin
Date Tue, 01 Jul 2008 18:40:03 GMT
Hi all.  My current project is using OpenJPA 1.0.2 and has been working
beautifully for months now.  I recently grabbed the newly released 1.1.0
version, dropped in the openjap.jar and serp.jar into my classpath,
started the server and got:

 

--- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---

ObjectName:
persistence.units:ear=eship.ear,jar=eshipEJB.jar,unitName=unishippers

  State: FAILED

Reason: java.lang.RuntimeException: java.lang.NoSuchFieldError:
brokerPlugin

 

in my main EAR file.  I didn't change anything else, just dropped in the
new JAR's.  I've done this in the past with new versions of OpenJPA with
no problems.  I did remember to re-enhance my entity beans after adding
the new JAR's, so I'm at a loss as to what is causing this problem.  Any
help would be greatly appreciated.

 

Thanks,

 

Eric


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message