openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <adam....@cyberspaceroad.org>
Subject Re: specifying schema in snapshot 1.1.0
Date Tue, 08 Jan 2008 16:26:09 GMT
Hi Prashant,

at the src code webpage for ConfigurationImpl.java, it showed no changes to the 
relevant code to fix the situation you had.

I just tried to build from src in maven and it's not working.

I'm using the binaries from 
http://openjpa.apache.org/builds/1.1.0-SNAPSHOT/downloads/ - that is revision # 
420667:609825.

But I do see the output from Runtime.Trace and it shows the 
openjpa.jdbc.Schema=DEV as I configured it.


Regards
Adam



Prashant Bhat on 08/01/08 15:39, wrote:
> Hi,
> 
> I'm using a very recent build(r420667:607583M) and it's working for
> me. Actually the above change you mentioned, has been already
> committed.
> 
> I use in persistence.xml the poperties like this:
>  <properties>
>          <property name="openjpa.jdbc.Schema" value="myschema" />
> </properties>
> 
> Regards,
> Prashant
> 
> On Jan 8, 2008 10:22 PM, Adam Hardy <adam.sql@cyberspaceroad.org> wrote:
>> Adam Hardy on 08/01/08 14:14, wrote:
>>> I'm having problems specifying the schema in my queries and it looks
>>> like it is due to a change in the source code as outlined here:
>>>
>>> http://www.nabble.com/forum/ViewPost.jtp?post=13987318&framed=y
>>>
>>>
>>> It seems to be a bug but there isn't a Jira in the issue tracker so I'm
>>> wondering what the situation is.
>>>
>>> Now that I have to use schemas, is there an easier work-around than
>>> putting all my mapping files' named queries inside <entity> tags with
>>> table attributes specifying the schema? (I assume that would work, but I
>>> haven't tried it yet).
>>
>> Just tried the work-around I was thinking of, and couldn't get it to work. Is
>> there any other possible work-around?


Mime
View raw message