openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Java_James <james-j...@rogers.com>
Subject Re: merge with new instances
Date Wed, 29 Aug 2007 19:36:50 GMT

Hey guys,

I'm having this exact same problem.  Was there ever a solution to this?

To answer the questions asked earlier on:

>>>> 1. What is the type of the primary key? If it is a primitive,  
>>>> and you change it to be a wrapper type (e.g., java.util.Long  
>>>> instead of long), does it change anything?

I originally had my pk as an int, but changed it to java.util.Integer, but
it did not doing anything

>>>> 2. Does this happen for all key values you have tried, or is  
>>>> there a specific one for which it fails? Specifically, I am  
>>>> wondering if this happens with id=0 (which we have had some  
>>>> problems with historically).

My problem occurs regardless of the primary key value

>>>> 3. Is the instance being serialized/deserialized before it is  
>>>> getting merged?

It does.  I am using a client/server webapp

>>>> 4. If you enable SQL logging, do you see any lookups being  
>>>> attempted when you call merge()? 

Any tips on how to enable the SQL logging?  I know lookups work, but I do
not know if they work during merge()

Thank you in advance


-- 
View this message in context: http://www.nabble.com/merge-with-new-instances-tf4082904.html#a12394258
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message