openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From janek <openco...@gmail.com>
Subject Re: Subclasses instances and query
Date Tue, 14 Aug 2007 09:59:16 GMT

I tryed latest 1.0 and problem is still there. I also tryed HSQLDB and it
have the same problem. 

And problem is not definitely on my machine, I reproduced this bug on
another computer by modifing HelloJpa sample which is comming with OpenJPA. 

As I wrote, logs and source codes are here:

http://www.nabble.com/file/p12095237/jpaProblem.zip
http://www.nabble.com/file/p12095237/Fill.log
http://www.nabble.com/file/p12095237/Test.log

Regards,
Jan


janek wrote:
> 
> Hi Craig,
> 
> In attachment is entire Eclipse project. Just add dependencies and
> enhancer agent. It is running on Derby.
> 
> The catch is that you must completely shut down EntityManager and Derby to
> reproduce this problem.
> 
> First run Fill main method, it will create database and put two Audi
> instances there. After that it makes two queries which show that problem
> does not appear here. 
> ie: "SELECT c FROM Car c" returns two Audi instances how it should be
> 
> After thet run Test main method. It will make two same queries, but it
> does not return Audi, but Car. 
> 
> Full log from my machine is attached. 
> 
> Jan
> 
>  http://www.nabble.com/file/p12095237/jpaProblem.zip jpaProblem.zip 
>  http://www.nabble.com/file/p12095237/Fill.log Fill.log 
>  http://www.nabble.com/file/p12095237/Test.log Test.log 
> 

-- 
View this message in context: http://www.nabble.com/Subclasses-instances-and-query-tf4249297.html#a12141773
Sent from the OpenJPA Users mailing list archive at Nabble.com.


Mime
View raw message