openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yogesh Rao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2607) Import range for javax.transaction is to small
Date Mon, 14 Dec 2015 09:11:46 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2607?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15055678#comment-15055678
] 

Yogesh Rao commented on OPENJPA-2607:
-------------------------------------

Hi,

I am intrested in this fix, when would the next version get released ?

> Import range for javax.transaction is to small
> ----------------------------------------------
>
>                 Key: OPENJPA-2607
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2607
>             Project: OpenJPA
>          Issue Type: Improvement
>          Components: osgi
>    Affects Versions: 2.2.2, 2.3.0, 2.4.0
>            Reporter: Christian Schneider
>            Assignee: Mark Struberg
>             Fix For: 2.4.1
>
>         Attachments: OPENJPA-2607-1.patch
>
>
> Currently the import for javax.transaction looks like this:
> javax.transaction.*;version="[1.1.0,1.2)";resolution:=optional
> Unfortunately this makes openjpa incompatible with jta 1.2 which should be compatible
for a consumer. As the Aries blueprint transaction support now uses jta 1.2 it does not work
with openjpa.
> I just change the import range on trunk and tested using the aries itests. 
> It seems openjpa works fine with jta 1.2 if the import range is corrected like below:
> javax.transaction.*;version="[1.1.0,2)";resolution:=optional
> I only tested with trunk (2.4.1-SNAPSHOT) but the increased range should work for 2.3.x
and 2.2.x too.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message