openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2514) ASM dependency revisited
Date Wed, 09 Jul 2014 12:43:04 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14056183#comment-14056183
] 

Mark Struberg commented on OPENJPA-2514:
----------------------------------------

totally agree with Romain. I'd love to ditch serp and all the other old stuff we have here
and use xbean-asm5 instead. This would also solve the problem with Java8... Plus we know ASM5
very well already as we use it in OpenWebBeans, TomEE, Geronimo, etc.
The only problem is that I have absolutely no free cycles atm because I'm 100% busy with $$dayjob
where I can only work on the parts I need for the job (BatchEE, DeltaSpike and TomEE). And
all my sparetime is reserved for OpenWebBeans-2.0.
I hope to have a bit time for it after we pass the CDI-1.2 TCK in OWB.

> ASM dependency revisited
> ------------------------
>
>                 Key: OPENJPA-2514
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2514
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: kernel
>    Affects Versions: 2.2.2, 2.3.0, 2.4.0
>            Reporter: Rick Curtis
>            Assignee: Rick Curtis
>
> OPENJPA-2171 introduced a dependency on xbean-asm-4 and with this JIRA I'd like to revisit
that issue.
> On the mailing list the TomEE folks have pointed that they need a java 6 release with
xbean asm5(in support of runtime java8) and Kevin has even reverted a number of changes to
trunk to rollback some of the java7(compile) support changes. I put together a patch that
is similar to Romain's patch from OPENJPA-2171 that will selectively load whichever ASM library
is available for a given environment. The attached patch will also upgrade the packaged asm
dependency in openjpa-all to xbean-asm-5, but that could be changed depending on the environment.

> While I understand, and appreciate the need to insulate OpenJPA from ASM(breaking) changes,
I don't like the fact that to use OpenJPA a user is also required to use a special version
of ASM. There are scenarios where a user might already have their own 'blessed' version of
ASM in use, and they don't want to have yet another copy. Allowing for selecting loading of
a given ASM library should be able to satisfy both use cases.
> If this seems like a reasonable way forward, I could commit this change to trunk and
2.3.x. This would mean that the TomEE folks could cut another release from the 2.3.x branch,
rather than creating yet another branch for limited benefit. 
> Thoughts, comments?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message