openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Curtis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2487) upgrade openjpa to asm5 to support java 8
Date Mon, 07 Apr 2014 22:18:25 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2487?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13962327#comment-13962327
] 

Rick Curtis commented on OPENJPA-2487:
--------------------------------------

Does TomEE need to be built at a Java 1.8 source level, or just needs to run on java 1.8?

> 2) is 2442 linked to dynamic proxying? If so we still have static enhancement.
Static enhancement will not solve this problem. This bug is related to our dynamic proxies
that get created for tracking non-standard types.

>  If not openjpa enhancement should be rewritten with full asm support since serp is not
upgraded anymore.
Great idea, but it is not a trivial task... and I don't know who is going to step up and do
the work.

> upgrade openjpa to asm5 to support java 8
> -----------------------------------------
>
>                 Key: OPENJPA-2487
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2487
>             Project: OpenJPA
>          Issue Type: Task
>            Reporter: Romain Manni-Bucau
>         Attachments: openjpa-asm5-release.patch, openjpa-asm5.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message