openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2487) upgrade openjpa to asm5 to support java 8
Date Mon, 07 Apr 2014 16:25:15 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2487?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13961978#comment-13961978
] 

Kevin Sutter commented on OPENJPA-2487:
---------------------------------------

Right.  Unfortunately, Java8 has introduced some incompatibilities with the OpenJPA test suite.
 As soon as I try to build the junit test suite with Java 8 (and asm 5), I immediately hit
the issue documented by openjpa-2442.  So, we could go ahead with your patch since it doesn't
affect the Java 7 usage pattern. But, it does not resolve the overall issue of using Java
8 with OpenJPA applications.

> upgrade openjpa to asm5 to support java 8
> -----------------------------------------
>
>                 Key: OPENJPA-2487
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2487
>             Project: OpenJPA
>          Issue Type: Task
>            Reporter: Romain Manni-Bucau
>         Attachments: openjpa-asm5-release.patch, openjpa-asm5.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message