openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Heath Thomann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OPENJPA-2478) Erroneous message from the enhancer when a Mapped Superclass contains an @Id.
Date Wed, 12 Feb 2014 18:17:20 GMT
Heath Thomann created OPENJPA-2478:
--------------------------------------

             Summary: Erroneous message from the enhancer when a Mapped Superclass contains
an @Id.
                 Key: OPENJPA-2478
                 URL: https://issues.apache.org/jira/browse/OPENJPA-2478
             Project: OpenJPA
          Issue Type: Bug
          Components: Enhance
    Affects Versions: 2.2.2, 2.1.2, 2.2.1.1, 2.3.0, 2.4.0
            Reporter: Heath Thomann
            Assignee: Heath Thomann
            Priority: Minor


HI!  I've discovered an issue which is pretty much as described in JIRA OPENJPA-2463.  That
is, when I have a MappedSuperclass with an @Id, I see this error:

openjpa.Enhance: Error: The identity field defined in the com.yyy.zzz.MyEntity Embeddable
is not supported.

This error message is erroneously printed because of the fix via JIRA OPENJPA-2233.  This
JIRA was well intended for the case where an @Embeddable contains an @Id (a spec violation)
but was too over reaching in that it also flagged an error for a MappedSuperclass with an
@Id.  I will provide a fix to ensure the error message is only printed when an @Embeddable
contains an @Id.

Thanks,

Heath Thomann




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message