openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Bauer <techhu...@gmail.com>
Subject Re: StackOverflow when enabling logging in openjpa-2.2.2
Date Mon, 01 Jul 2013 14:42:38 GMT
Hum.  I'll check into that.  I wouldn't have expected a basic log4j config
to cause that failure.  Have you tried a 2.2.3 snapshot?

-Jeremy

On Mon, Jul 1, 2013 at 9:06 AM, Mark Struberg <struberg@yahoo.de> wrote:

>
>
> nope, it's standard openjpa.Log=log4j which caused a nice
> StackOverflowException.
> Wait, maybe it depends how we pass this info. I'm pushing it into the
> Properties passed in to  createEntityManagerFactory(Map)
>
>
> LieGrue,
> strub
>
>
>
> ________________________________
> From: Jeremy Bauer <techhusky@gmail.com>
> To: dev@openjpa.apache.org; Mark Struberg <struberg@yahoo.de>
> Sent: Monday, 1 July 2013, 15:58
> Subject: Re: StackOverflow when enabling logging in openjpa-2.2.2
>
>
>
> Hi Mark,
>
> I fixed an issue in that area in several code streams, but it *should* be
> an extremely odd case where you'd hit it.  What do you have configured for
> a logger?  Is it a custom logger?
>
> -Jeremy
>
>
> On Mon, Jul 1, 2013 at 6:48 AM, Mark Struberg <struberg@yahoo.de> wrote:
>
> Hi folks!
> >
> >
> >There is a bug in openjpa-2.2.2 which renders it pretty much useless for
> production I fear.
> >
> >If we enable logging then openjpa blurps out with a
> StackOverflowException at startup.
> >
> >I've seen Jeremy already fixed this issue in trunk, but there is no JIRA
> ticket nr in the commit.
> >Is there such a ticket?
> >
> >Is there a workaround? Or shall we prepare a 2.2.3 release to ship it?
> >
> >txs and LieGrue,
> >strub
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message