openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Curtis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2399) Oracle JDK 1.7 seems to be causing an issue with OpenJPA
Date Fri, 14 Jun 2013 14:53:20 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13683414#comment-13683414
] 

Rick Curtis commented on OPENJPA-2399:
--------------------------------------

Note, this problem only occurs when using runtime enhancement via the -javaagent or the DynamicEnhancementAgent.
                
> Oracle JDK 1.7 seems to be causing an issue with OpenJPA
> --------------------------------------------------------
>
>                 Key: OPENJPA-2399
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2399
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 2.2.0, 2.3.0, 2.2.2
>            Reporter: garpinc
>
> I recently had to upgrade to JDK 1.7 and I'm having
> java.lang.LinkageError: loader (instance of  sun/misc/Launcher$AppClassLoader): attempted
 duplicate class definition for name: "org/apache/openjpa/jdbc/identifier/DBIdentifier$DBIdentifierType"
> I previously reported this sometime ago here:
> http://openjpa.208410.n2.nabble.com/JDK-1-7-seems-to-be-causing-an-issue-with-latest-snapshot-td7581417.html#a7583248
> seems there has been no resolution. I've tried 2.2.0, 2.2.1 and 2.3.0-SNAPSHOT and all
have same issue on Oracle JDK 1.7. Can someone please advise?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message