openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter (JIRA)" <>
Subject [jira] [Commented] (OPENJPA-2388) support new xbean asm4 shade
Date Thu, 06 Jun 2013 20:56:20 GMT


Kevin Sutter commented on OPENJPA-2388:

I'm confused by this latest commit.  As far as I can tell, OpenJPA only has a dependency on
ASM 3.2 (kernel's pom.xml).  Although I agree that the changes you are introducing probably
will help ASM 4 usage when we get there, I don't understand why this change was necessary
when we haven't moved to ASM 4 yet...  And, I'm not clear on this usage of the org.apache.xbean.asm
and org.apache.xbean.asm4 package.  So, we're modifying OpenJPA code everytime some user of
OpenJPA has a shaded version of ASM?  That doesn't sound very scalable...  What am I missing?
> support new xbean asm4 shade
> ----------------------------
>                 Key: OPENJPA-2388
>                 URL:
>             Project: OpenJPA
>          Issue Type: Task
>            Reporter: Romain Manni-Bucau
>            Assignee: Mark Struberg
>             Fix For: 2.3.0
>         Attachments: openjpa-asm4-shade.diff

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message