openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dick <>
Subject Re: Exporting website from CWIKI
Date Thu, 15 Nov 2012 02:41:59 GMT
Sorry I can't reply much during the work day I'll try answer everything.

On Wed, Nov 14, 2012 at 4:45 PM, Kevin Sutter <> wrote:

> Okay, I think I'm giving up on the Windows approach...  The build scripts
> all seem to require .sh scripts and other linux-specific items.  I might
> follow Rick's lead and try a VMWare linux image...

Believe it or don't, I tried Windows first too. And gave up.

> Maybe Mike is the only one that can get this build running and we just need
> to pitch to in $20 per to buy him a nice dinner...  :-)

Preferred payment plan is 25 year old Highland Park (will also accept Old


> > cpan SVN::Client
> >
> > These all seemed to work except for the SVN::Client module.  This one
> > seemed to require a different build process and it eventually blew
> chunks.
> > I don't know if this module is really needed or not.  I'll try a couple
> of
> > other things, but otherwise, I'll move on and see if I really need it.

I think I had a similar problem, but it just worked for me. The build
scripts don't commit anything so I think it's not needed.


> >> setuptools, pygments and ElementTree installed with no problem. However
> >> when tried to install Markdown, I got:
> >>
> >> [root@atlanta ~]# sudo easy_install Markdown
> >> Searching for Markdown
> >> Reading
> >> Reading
> >> Reading
> >> Reading
> >> Reading
> >> Best match: Markdown 2.2.1
> >> Downloading

You might have better luck if you use apt (debian based distros) or yum
(RedHat based) to directly install the python module for markdown. I'm
guessing you're on RHEL, so I can't help much, other than I think it's
sudo yum --search markdown (then install the one with python)

That said:

> >>
> "/usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/",
> >> line 64, in <lambda>
> >>     {'__file__':setup_script, '__name__':'__main__'}
> >>   File "", line 130
> >>     with'docs/_template.html', encoding='utf-8') as f:
> >>               ^
> >> SyntaxError: invalid syntax
> >> [root@atlanta ~]#
> >>
> >>
> >> Any idea why it has SyntaxErro on the codecs token in

You need to update python. The 'with' syntax was introduced in python 2.6
or 2.7 I think. Yum / apt should help here.

Regarding the files to edit : look for the mdtext ones, those are markdown
format. More advanced web developers than me may build templates and other
cool things! But I just wanted to get the site to look more or less
correct. The cwiki extension should be the original confluence wiki text,
and I'm not sure what the files without extensions are.

Regarding locking the files, well, we've never had to lock files before,
and I don't know a good way to do so right now. If folks want to sign up
for a page we could add a table to the wiki (no irony there), resurrect the
irc room, or just email when we're starting to work on a page.

Perhaps my brute force approach really isn't the best way to go about this.
I suspect that there are lot of pages which aren't needed or aren't
reachable anymore. Status pages, placeholders (tables of contents, etc.),
and legacy pages could be saved off and coverted later. I didn't go through
an identify those pages before I committed them - partly because I ran out
of time, and partly because I didn't want to be the only one to make the


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message