openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Kubowicz (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OPENJPA-2300) Enhancer shows warnings when executed on Java 7 sources
Date Mon, 26 Nov 2012 09:06:57 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-2300?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Piotr Kubowicz updated OPENJPA-2300:
------------------------------------

    Description: 
When running {{openjpac}} Ant task on Java sources set to Java 7 compatibility, the following
warning is shown:

    [javac] warning: Supported source version 'RELEASE_6' from annotation processor 'org.apache.openjpa.persistence.meta.AnnotationProcessor6'
less than -source '1.7'

This is because AnnotationProcessor6.java contains:

@SupportedSourceVersion(RELEASE_6)

which according to JDK documentation means that this annotation processor is incompatible
with Java 7.

  was:
When running {{openjpac}} Ant task on Java sources set to Java 7 compatibility, the following
warning is shown:

    [javac] warning: Supported source version 'RELEASE_6' from annotation processor 'org.apache.openjpa.persistence.meta.AnnotationProcessor6'
less than -source '1.7'

This is because AnnotationProcessor6.java contains:

@SupportedSourceVersion(RELEASE_6)

    
> Enhancer shows warnings when executed on Java 7 sources
> -------------------------------------------------------
>
>                 Key: OPENJPA-2300
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2300
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: Enhance
>    Affects Versions: 2.2.1
>         Environment: OpenJPA 2.2.1
>            Reporter: Piotr Kubowicz
>            Priority: Minor
>              Labels: java7
>
> When running {{openjpac}} Ant task on Java sources set to Java 7 compatibility, the following
warning is shown:
>     [javac] warning: Supported source version 'RELEASE_6' from annotation processor 'org.apache.openjpa.persistence.meta.AnnotationProcessor6'
less than -source '1.7'
> This is because AnnotationProcessor6.java contains:
> @SupportedSourceVersion(RELEASE_6)
> which according to JDK documentation means that this annotation processor is incompatible
with Java 7.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message