openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject [DISCUSS] Upgrade to use ASM 4 for our post-enhancement processing
Date Thu, 25 Oct 2012 13:15:01 GMT
Hi,
Some of you may have noticed a recent JIRA I opened up:
https://issues.apache.org/jira/browse/OPENJPA-2283

I created this for upgrading our current usage of ASM 3.2 to ASM 4.0.
OpenJPA uses ASM for some post-enhancement processing to clean up the stack
map tables that are required for Java 7 validation.  Since ASM 4 has more
complete support for Java 7, I thought it would be an easy,
preventative-care type of move.

As my JIRA indicates, I have run into a couple of hiccups with this move
that I am still working through.

But, in general, does anybody have a concern with this upgrade?  I'm only
looking to do trunk at the moment.  But, if we continue to hit Java 7
validation errors in 2.2.x, then I might consider moving it back to 2.2.x
as well.

Thanks for any input,
Kevin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message